This project has moved. For the latest updates, please go here.

Problem opening the sample.xlsx

May 18, 2010 at 2:22 PM

Hello there

I just downloaded the latest version and unzipped the websamples. I could generate sample1.xlsx, But could not open the same. It says some of the contents of the files are unreadable :( and asks whether It should search for a converter and ends up in http://support.microsoft.com/kb/967950 I am running Microsoft Excel 2007. Any help?

Kit

 

Coordinator
May 18, 2010 at 7:02 PM

Hi,

Im not sure why you get this error message. The samples should work fine with Excel 2007.

The sample requires that Visual studio 2008 and Excel 2007 is installed on your computer.

Try the other samples (the command line) and see if you can open them.

May 18, 2010 at 7:24 PM

Hi Jan

I dont understand what do you mean by commandline samples. I am talking about the websamples. I created 3 sample files - 1,2, and 3 and the same problem exists in all the three. I run VWD Express. Could that be the problem?

Kit.

 

Coordinator
May 18, 2010 at 8:01 PM

Ah, I guess you cant run the command-line sample project then (it's included in the solution-file). I just wanted to see if you could get it to work at all. 

I havn't tried the express version, so I really dont know if that is the problem.

Any one else has?

May 19, 2010 at 8:57 AM

Jan, I tried to run the windows application sample and could create sample 1,5,6 and 7 (okay I didnt have the adventureworks installed so 3 and 4 were not generated). and to my surpise I could open all the four documents (I should tell you that I am so impressed). Again I am running visual C# 2008 express edition.

I will now try to create a new website and try to implement your samples and get back to you.

Meanwhile any tips would be appreciated.

Kit

May 19, 2010 at 1:53 PM

Yahoooooooooooooo! It works!!! When I created a new project and reproduced your code, it runs perfect :)

I  have a two quick questions.

1. If I write worksheet.Cells["A2"].Value = "12001" (Your ID Column) In the Excel sheet I see an Error message against this value something like "The number in this cell is formatted as Text..." (I have an German version of Excel and the translatation I had given is not exact, but am sure you will understand what I mean). whats the work around?

2. The documnetation (EPPlus2.6.chm) poses some problem. Am not able to navigate through the listings. It says something like "The navigation to his website is broken..." (Needless to say, German OS and I've tried my best to translate)

  Anyways thanks a million for such a wonderful utility. I am now all set to explore it. Pls dont mind If I bump often with questions. 

Cheers
Kit

 

 

 

 

 

Coordinator
May 19, 2010 at 5:44 PM

Great! :)

Your questions...

1. Change it to a numeric datatype, like worksheet.Cells["A2"].Value = 12001

2. Windows blocks it. Make sure you run it from a local drive. If you run Windows 7, right-click the chm file--> Properties. You should find the unblock button on one of the tabs. Look at issue 10578 for more info.

Jan

May 19, 2010 at 8:32 PM

Perfect :)