This project has moved and is read-only. For the latest updates, please go here.

IsolatedStorage problem

Jan 8, 2012 at 7:48 PM

Hi and thank you for an excellent product!

I've made a tool that is running under SqlAgent to generate excel docs. It works fine as long as the file is not to large. It also works fine it it's not started from the SqlAgent account. When the file grows larger I get the IsolatedStorage problem mentioned in the two links below.

I've found these great articles but none of them solves my problem:

I've found three different ways of working around my problem.

1. Create the appropriate directories with appropiate permissions. I'm running Sql Server 2008 R2 and no matter where and how I precreate the IsolatedStorage directory it does not work. I've tried in both the public profile and in the profile that SqlAgent is using.

2. Delete the profile which SqlAgent is running under (this is not an option for me).

2. Create a new app domain

I've tried this option and it might still be an option but i got into problemes with the [serializable] attribute that I had to add to the classes...


My next option is to actually go through and modify the epplus source. I would really like to avoid that. Therefore I'm kindly asking this forum for help.
I'm quite certain that the problem has to do with the permission problem that is mentioned by Svante in the link above.

Does anyone have a solution for my problem?